OS X 10.11 El Capitan öffentliche Beta – Arduino Probleme mit Typ CH340 [gelöst]

Update 22.10.2015 CH340 Probleme gelöst?
CH340 klicken um zu vergrößern

CH340 klicken um zu vergrößern

Ich bastel ja gerne mit den preiswerten Arduino-Clones, hier vom Typ CH 340 (amazon.de -> Aukru Nano v3. 0 Bausteine ATMEGA328P elektronische interaktive Medien mit USB/Dupont-Kabel
). Die Dinger kann man ideal als Mikrocontroller für Sensoren, Jeelinks usw. verwenden. Ebenfalls teste ich auch gerne die neueste Apple Software. Hier die öffentliche Beta el Capitan OS X 10 11. So kommen irgendwann beide Welten zusammen, um ein Arduino CH 340 zu flashen. Beim aktuellen Yosemite Betriebssystem gab es anfangs auch Probleme, der Arduino-Nano Clone wurde zuerst nicht erkannt. Die Lösung habe ich hier in einem Blog-Beitrag verfasst, siehe hier. Hier in der neuesten Version vom Apples Betriebssystem muss ich allerdings passen. Falls es eine Lösung dazu gibt, werde ich es an diese Stelle publizieren. Arduinos (uno, nano, pro mini) mit FTDI-Schnittstelle (amazon.de -> Arduino Nano V3.0 mit USB-Kabel (gratis)
) gab es keine Probleme. Blieb mir also nur noch ein Restore meines Betriebssystems auf die derzeitig aktuelle Version mit der TimeCapsule (amazon.de Apple ME177Z/A AirPort Time Capsule
). Klappte übrigens super.

Update: 22.10.2015 Blog-Leser Enrico (sein Kommentar wurde durch den Serverwechsel leider gelöscht, hatte folgende Lösung:

Kommentar:
„System Integrity Protection“ teilweise ausschalten:
- Im Recovery Mode starten "CMD + R"
- Terminal aufrufen:
1. csrutil disable
2. dazwischen musste ich die Arduino IDE neu installieren wegen diverser Einstellungen
3. csrutil enable --without kext

 

Dieser Beitrag wurde unter Apple-Pie, Hardware veröffentlicht. Setze ein Lesezeichen auf den Permalink.

2 Antworten zu OS X 10.11 El Capitan öffentliche Beta – Arduino Probleme mit Typ CH340 [gelöst]

  1. Robin sagt:

    Hallo Roadrunner,
    danke für die Info. Wenn ich das nächste mal wieder auf El Capitan upgrade, werde ich es ausprobieren. Derzeitig ist mir das Arbeiten mit den Arduino Nanos wichtiger als die Apple Beta Version.

    LG
    /robin

  2. Roadrunner sagt:

    Vielleicht liegt es an der „System Integrity Protection“ von El Capitan. Ich hatte auch Probleme mit meinem Kartenleser nach dem Update auf El Capitan. Der Treiber für den Kartenleser wurde mit dem Update deinstalliert und die erneute Installation scheiterte dann an der „System Integrity Protection“.

    Die Lösung war aber recht simpel. Einfach den Rechner von der Recovery-Partion booten und dann unter „Security Configuration“ von „Utilities“ die „System Integrity Protection“ deaktivieren. Danach konnte der Treiber wieder installiert werden und der Kartenleser funktionierte wieder ohne Probleme.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.